Unable to install imblearn

Pls find the below error for using SMOTE

Can someone help on this

Hi I had the same issue in google colab, I made a copy of the notebook so the environment was a new one and it worked. Sorry I have no more explanation, especially that when I tried to install six, it said it was already installed :-/.

Hello Manohar,

I had the same issue.after installing imblearn forassignment 1. Read the following thread as it helped me https://stackoverflow.com/questions/61867945/python-import-error-cannot-import-name-six-from-sklearn-externals

I didn’t import mlrose though as it was specific to that person’s problem

1 Like

Hi @manohar
Is your problem resolved? If not try following @sandra solution

Hi @manohar :slight_smile: Sorry for the late reply. But this is the same problem that I was also facing and searched a lot for it.
Then I found the solution that worked for me-

  1. Install imblearn in jupyter notebook using
    !pip install -U git+https://github.com/scikit-learn-contrib/imbalanced-learn.git
  2. import six along with imblearn

This will solve the issue. :slight_smile: