Day 0: Setting Up TensorFlow

  • Option 1: Setting TensorFlow through Google Colab is seamless and recommended for beginners
  • Option 2: You can set up TensorFlow on the device if your laptop/desktop has good configuration

There are pros and cons for both the options. Also, please remember these (colab/jupyter notebook/tensorflow) are merely tools/frameworks and we shouldn’t get stuck if we are unable to resolve them. Deep Learning and Data Science practices are about solving a problem using “data” in a “scientific” way. And in the process, the above tools and techniques would help, and if required we should go about inventing new tools and techniques,

Please feel free to post any queries about the Day 0 unit here.

Updated by @chanukya


Hi, I’ve been trying to install tensorflow following the guideline (anaconda installation method) in the video tutorial attached to the slides. I keep getting this error.

NotWritableError: The current user does not have write permissions to a required path.
path: /Users/user/anaconda3/pkgs/cache/53d7ef51.json
uid: 502
gid: 20

If you feel that permissions on this path are set incorrectly, you can manually
change them by executing

$ sudo chown 502:20 /Users/user/anaconda3/pkgs/cache/53d7ef51.json
I guess this means I’m supposed to change ownership, I did a few research and I’m still not able to resolve this issue. Do you recommend I unistall and re-install anaconda? Or how can I resolve this please?

1 Like

Another question please, I’ll like to install tensorflow on my system. Is Intel Iris plus Graphics 655 a good enough GPU to run Deep learning models.

I’ve resolved this issue using an alternative method. Instead of installing tensorflow via Anaconda UI interface, conda install tensorflow worked fine.


Thank you for sharing your solution @omobolaji!
I’m sure it will help others facing the same issue.

1 Like

No, since the CUDA technology is only limited to Nvidia GPUs. I am on an AMD GPU and faced some problems installing the GPU version in past.

1 Like

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:


  • tensorflow -> python[version=‘3.5.|3.6.|3.7.*’]

Your python: python=3.8

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify

The following specifications were found to be incompatible with your CUDA driver:

  • feature:/win-64::__cuda==11.0=0
  • feature:|@/win-64::__cuda==11.0=0

Your installed CUDA driver is: 11.0

Q: if i reinstalled phyton, does it change the whole environment? i am afraid there would be more errors, or is there any solution?

Oh, alright then. Thank you. Does this mean “Colab” is the only option I have, or is there a way around working with tensorflow locally?

1 Like

You can install the CPU version and work with that.


After setting up the tensorflow-gpu enviroment in anaconda navigator facing an error in installing jupyter notebook. What should I do ?They are showing some unsatisfiable Specifications error

1 Like

@chakraborty.debadrit It is difficult to comphrehend what the error exactly is about. It is possible that you didn’t launch “Anaconda Navigator” as an admin and hence the error. Refer this for more details around this.

Also, to avoid these setup issues, I would recommend trying Google Colab which is seamless to setup TensorFlow.

1 Like

you can also try to run jupyter notebook from command_prompt(windows)/terminal(linux/mac).

1 Like

Thank you.Its working now after launching as admin.

For those of you who want to install Tensorflow 2 using the Conda package manager:


  1. Only works if you have a dedicated Nvidia GPU in your system
  2. Python version 3.7.7 or above
  3. Anaconda with latest Conda version


  1. Install the Latest GPU drivers (you can find them here for your respective GPU)
  2. Go into Ananconda Prompt, and enter conda install tensorflow-gpu=2.0 python=*YourPythonVersion*


Please note that this method installs Tensorflow 2 on your base environment.

In case you want to install it in a new environment, you can clone your existing base environment and follow the same process as above
Cloning will save you from the process of having to reinstall jupyter and other libraries that you already have in your base

I found the above method here.


I am getting this error for most of my conda tensorflow commands.I have cloned my base env in beginning.

@kshitik running conda install anaconda might solve the issue, you can find a similar issue referenced here:

Exact same inconsistency issues comes and which cause some new downloads n installation of packages which finally interrupts as


Hi @kshitik
Can you have a look at Programs and Features in your device and see if there’s no separate Python package installed? If there is a Python installation apart from the Anaconda one, please remove it.
Also, ensure only one version of Anaconda is installed

I checked but couldnt found any version of python in apps and features(strange) though I have Anaconda installation idk y isnt it showing up in apps and features. I have spent whole day figuring out but couldnt. If u can find some hint in the screen recording it ll be great else cool(Last option left was this recording sorry for music behind )

Thanks for the detailed video @kshitik!
Can you go to “Edit the environment variables” --> Environment Variables --> user variables --> Path
and see if Anaconda is present there?
Sometimes it is not added to the path and that causes the error.